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sucanonaL GO | earning Outcome of this session

Student will able to IMPLEMENT MAIL MERGE

= Demonstrate to print the label using mail merge, do the following to achieve
= Create a main document,

= Create the data source,

= Enter data in the fields,

= Merge the data source with main document,

= Edit individual document,

= Print the letter and address label

CHANGING YOUR TOMORROW

Website: www.odmegroup.org Toll Free: 1800 120 2316
Email: info@odmps.org Sishu Vihar, Infocity Road, Patia, Bhubaneswar- 751024



U_DH What is mail merge?

EDUCATIONAL GROUP

_OpenOfflgegrg (O0o0) Writer provides very useful features to create and print:
 Multiple copies of a document to send to a list of different recipients (form letters)
* Mailing labels
 Envelopes

All these facilities, though different in application, are based around the concept of a
registered “data source”, from which is derived the variable address information
necessary to their function. This chapter describes the entire process. The steps include:

1. How to create and register a data source.
2. How to create and print form letters, mailing labels, and envelopes.
3. Optionally, how to save the output in an editable file instead of printing it directly
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EDUCATIONAL GROUP Creating the data source

A data source is a database containing the name and address records (and optionally
other information) from which a mailing list may be derived. Although you can create
and print mailing labels and envelopes without using a data source, in most cases
using one is the best approach. This chapter assumes that you are using a data source.
OOo can access a wide variety of data sources, including spreadsheets, text files and
databases such as MySQL, Adabas, and ODBC. If the information to be used in the mail
merge is currently in a format that OOo cannot access directly, you need to convert it,
for example by exporting it to a comma-separated values (CSV) file. For the following
example we use a spreadsheet with the following column (field) headers: Title, First
name, Last name, Address, State/County, Country, Post Code, Sex, Points. A sample
data source is shown in Figure 1.
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File Edit View Insert Format Tools Data Window Help
B-ecla R 28R VR LhR-¢ 6-0- &4
- by | Avial v 10 v B 7 U |=s===sH HHEH|
E6 v f B = |Exeshie
A B C D E F G H I
1 Title  First Name LastName Address State/County Country PostCode |Sex Points
2 Mrs.  Alice Azure 1, First Avenue Ampshire ALY 1AA  |F a7
_ Awerage Town
3 Mr Brian Brown 2. Bottom Lane Burkshire BB2 2BB M 91
Bilbarough
Figure 1: Spreadsheet data source
CHANGING YOUR TOMORROW
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Registering a data source

For a data source to be directly accessible from within a Writer document, it must first
be registered as described below. You only need to do this once; after that, the data
source is available to all documents in OpenOffice.org.

1. From within any Openoffice.org document, or from the OpenOffice.org Welcome
screen, choose File > Wizards > Address Data Source.

Ble Edit View Insert Format Table Tools Window Help
. Hew "B S R V=
=% Open... Ctrl+0 —
Recent Documents v [Times New Homan M |12 '
Wizards » [0 Letter., . .
2 g i3 Fax... Figure 2: Starting the Address Data
¥y Close - .
EH save Culeg | [0 Agenda... Source wizard
Bl saveas.. cul+shift+s | (o Presentation...
Save All “; Web Page...
% Rejoad f .;I Document Converter..,
Versions. . f.;l Euro Converter. ..
| & Boort. o Address Data Source
= o] R \UR TOMORROW
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2. The choices on the first page of the wizard vary with your operating system. Select

the appropriate type of external address book. In this example, it is Other external
data source. Click Next.

-~

Address Book Data Source Wizard ﬁ
Steps OpenOffice.org lets you access address data already present in your system. To
do this, a OpenOffice.org data source will be created in which your address data
1. Address book type is available in tabular form.
2. Connection Settings This wizard helps you create the data source.

Please select the type of your external address book:
i_) Mogzilla / Netscape
{_) Thunderbird
{_) LDAP address data
i) Dutlook address book
(_) Windows system address book

Help ] [ Mext == J [ Cancel

Figure 3: Select type of external address book
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3. On the next page of the Wizard, click the Settings button.

Address Book Data Source Wizard
Steps To set up the new data source, additional information is required.
1. Address book type Click the following button to open another dialog in which you then enter the

necessary information.
2. Connection Settings

|__iSettings |

Figure 4: Starting the Settings part of the Wizard
4. In the Data Source Properties page, select the Database type. In our example, it is

Spreadsheet. Click Next.

o =1

Data Source Properties: Spreadsheet ﬁ

Select the type of database to which you want to establish a connection.

Figure 5: Selecting the

Database type ISpreadsheet | v ||

database type
On the following pages, you can make detailed settings for the connection.
The newr settings you make will overwrite your existing settings.
Website: www.odmegroup.org Toll Free: 1800 120 2316
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5. In the next dialog box, click Browse and navigate to the spreadsheet that contains
the address information. Select the spreadsheet and click Open to return to this
dialog box. At this time you may wish to test that the connection has been
correctly established by clicking on the Test Connection button (not shown in
illustration).

Database properties - Connection settings ﬁ

General

Path to the spreadsheet document

D:\OODauthors\addresses-test.ods 1Elnri:m-.rf'..e l

User authentication

("] password required

Figure 6: Selecting the spreadsheet document
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6. Click Finish.

7. On the following page, click Next. Because this is a spreadsheet, do not click Field
, Assignment. 1
Address Book Data Source Wizard ﬁ

Steps To incorporate the address data in your templates, OpenOffice.org has to know
which fields contain which data.

1. Address book type
For instance, you could have storad the e-mail addresses in a field named

2. Connection Settings "email”, or "E-mail" or "EM" - or something completely different.

Click the button below to open another dialog where you can enter the settings

for your data source.
4.Field Assignment

O S CTSU S PP

i Figure 7: Because
5.Data Source Title [Q!_-‘i_e_v_l_1_:l_ g_s_es_;@mn_agg] this is a

spreadsheet, do
There are no fields assigned at this time.

You can either assign fields now or do so later by first choosing: not click Field
"File - Template - Address Book Source..." .
Assignment.

[ Help l [ << Back l l Next == [ Cance| ]
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8. Name the file in the Location field. The default is ...\Addresses.odb; but you may
replace Addresses with another name if you wish. You may also change the name
in the “Address book name” field. In our example, the name “Points” was used for

. both. ]
Address Book Data Source Wizard a
Steps That was all the information necessary to integrate your address data into

OpenOffice.org.

1. Address book type
Now, just enter the name under which you want to register the data source in

2. Connection Settings OpenOffice.org.
Location
D:\OOauthors\Points.odb v [ Browse... ]
4. Field Assignment
ST MAz;k: this:ddkress book available to all modules in OpenOffice.org. Flgu re 8: N ame the
ress book name
Points .odb file and the

address book.

| Help ] |  <<Back | | mnish ||  cance |

9) Click Finish. The data source is now registered.
CHANGING YOUR TOMORROW
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Example: Sending a letter to your customer base

A mail order company organized a campaign to assign
credit points to their customers according to the
quantity of goods they buy during one year.

At the end of the vear, they want to send a letter to each
customer to show the total of credit points collected.

You can create a form letter manually, which is the simplest and most comprehensive

method and is described here, or you can use the Mail Merge wizard as described in “Using

the Mail Merge Wizard to create a form letter”. If you select to use the wizard, pay close

attention to its current limitations, as identified within its description.

1. Create a new text document: File > New > Text Document, or open a pre-existing form
letter with File > Open.

2. Display the registered data sources: View > Data sources (or press F4).

3. Find the data source that you wish to use for the form letter, in this case Points. Expand
the Points and Tables folders, and select Sheetl. The address data file is displayed.
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fe Edt Vew Insert Fomst Table loos Wrdow Heb
Bl ae @ ESR VR IR -¢F oS- BRE-V N‘bﬁﬂﬁil‘ﬂQ@
\i;)'b&fsbn |v CentSchbook BT l_J:z JBIUNA. g'ii’&:;#m,ﬁ?g
W TABR A PO NSy ¥ e
5 AcdressBook w]mm]um]m]smw[m[mm[mlm]
a Bhgrachy Mrs.  Abce Agure 1, First Aver Ampshre . AAL JAA £ 67
B Points Me, Erian Beoan 2, Bottom Lz Bukshre 8582 53 w o1
5 (5 Queres Mr.  Chares  Coffes 3, Carter Cr Cropahre . ceIXe M
= Mrs, Dors Damson 4, Cespdale Ceepihire 004 40D = 512
BlSTables M.  Edwerd  Eamore 5 Basbeth Exeshre EESSEE M an
= Sheets; M,  Fredelc | Fartead 6, Foresight Fineshire SEEEE 0 M 23

Figure 9: Selecting the data source.
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4. Now create or modify the form letter by typing in the text, punctuation, line
breaks, and so on that will be present in all of the letters. To add the mail-merge
fields where needed (such as names and addresses), click in the field heading and
drag it to the appropriate point in the letter. (See Figure 10). Note that address
lines should be in individual paragraphs, not separated by line breaks as might
seem preferable. The reason for this will be made clear in the next step.

¢ -
Title | Firstklame | LastName |
P |Mrs. Alice Azure 1, First Avem
Mr. Brian Brown 2, Bottom Lar
Mr. Charles Coffee 3, Carter Cre
Mrs. Doris Damson 4, Deepdale |
Mr. Edward Eatmore 5, Elizabeth =
Click on data source Mr. Frederic Fairhead &, Foresight\ - . H H
e et Mr. George e S Geatnde  Figure 10: Dragging fields to the body of
Record J1 [of 10 o] the form letter

-.and drag to here to Z ..
insert fields in form letter

.J._....]:....J._....;...._:-....E...._L....i.

To9
» =Title> - <Firs-Name> -<Last-Name>1T
3 = Address="1
L 3 <State/County=T
3 <Post-Code="1T
——» —Country="T
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5. Continue until you have composed the entire document. (See Figure 11 for an
example.) At this time you may wish to consider suppressing any blank lines that

may appear in the resulting letters. If not, skip ahead to Step 7.
To
<Title> - <Frs-Name> -<Last-Name=1
<Address=>T
<State/County=1
< Post-Code=1
<Country=1
5-November-20079
Dear <Title>-<Last-Name> 1
Thank-you-very-much-for-your-participation-in-our-“ Points” promotion.-We-are-pleased i .
toinform-you-that-you-have-earned- <Points> this-year.d Figure 11: Thletiompleted form
etter.
Your-loyalty-to-our-company 1s-greatly-apprecated-and-we-hope-to-be-of continuing
servicein-thefuture 9

Yours-sincerslyl

General-Supply-ple-
Wetherbridge -» XX7-1YYY

CHANGING YOUR TOMORROW
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6. To suppress blank lines:

a) Click at the end of the first paragraph to be suppressed and then choose
Insert > Fields > Other.

b) Select the Functions tab and then click on Hidden Paragraph in the Type
column.

c) Now click in the Condition box and enter the details of the condition that
defines a blank address field. It has the general form of:

| [Database. Table. Database field]

where the ‘I’ (NOT) character indicates the negative case and the square
brackets indicate the condition. For example, in our Points database the
condition to test if the Company field is empty would be:
I[Points.Sheetl.Company] as illustrated in Figure 12.

d) Click Insert, but do not close the dialog box until you have amended all the
lines that should be suppressed.

CHANGING YOUR TOMORROW
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— —

Fields X

Document | Cross-references Functions | DocInformation | Variables Database

Type Condition

Conditional text - I[Points.Sheetl.Last Name]
Input list

Input field Figure 12: Hidden paragraph
Execute macro . .
Placeholder Insertion
Combine characters
Hidden text

Hidden Paragraph

[nsert ][ Close [ bep |

To test for multiple conditions use the operators AND and/or OR between the conditional
statements, for example:

I[Points.Sheet1.Title]AND![Points.Sheetl.Last Name]
CHANGING YOUR TOMORROW
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The document is now ready to be printed.
1) Choose File > Print and respond with Yes in the message box.

j') Your document contains address database fields. Do you want to print a form
letter?

Figure 13: Confirmation message for merging database fields
2) In the Mail Merge dialog box, you can choose to print all records or selected

records. To select records to be printed, use Ctrl+click to select individual records.
To select a block of records, select the first record in the block, scroll to the last
record in the block. and Shift+click on the last record

No Help |

YYCMIILT ., YYYYV Y. UUITITHIVUPY.VILE

Email: info@odmps.org

Mail Merge
: A | & =3 84 - 2 4l 3 x ¥ X 1= , 2, 2
g AddressBoo ~ I Title [ First Name l Last Name | Address \ State /Coun’
Q Bibliography Mrs., | Alice Azure 1, First AvenueAverage Town Ampshire ~
= g Points Mr. Brian Brown 2, Bottom LaneBilborough Burkshire | |

(5] Queries Mr. Charles Coffee 3, Carter CrescentCookstown Cropshire
Ay — i Mrs. Doris Damson 4, Deepdale RoadDartford Deepshire (+
‘ | > Record [1 | of 10 (2 ) = £ ' >
Records Output
O an (%) Printer O Eile
(&) Selected records [] single print jobs
O From: 1 To: 1
.-..Free: 1800 120 2316
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Mail Merge
XD » M- HU ¥l F=
2 AddressBoo A Tile | FirstName | LastName | Adci'ess
B2 Bubiography% _ | b iMrs,  iAkce Azure 1, First Ave - gh- NI
= a Points | Mr Brian Brown 2, Bottom Lane& orou i
() Queries: [Mr.  Charles Coffee 3, Carter CrescentCookstown
P | Mrs. Doris Damson 4, Deepdale RoadDartford
€l w | [2] Recordfi | of 10 (2) ‘e <] w
Records : Output
Oa @ Printer O Eie
(%) Selected records [] single print jobs
O Erom: 1 To: 1 | e

Figure 14: The Mail Merge dialog box
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3) Click OK to send the letters directly to the printer. If you prefer to save the letters
to a file, perhaps to allow proofreading or some later formatting, select File in the
output section of the Mail Merge dialog box, instead of using the default Printer
selection. This changes the dialog box to display the Save merged document
section, where Save as single document is pre-selected. You can choose to save
each letter as a single, individual document, if preferred.

In this case, clicking OK brings up the Save as dialog box. Enter a file name for the
saved letters. They will be saved consecutively in the single document, or
numbered consecutively in individual files if saved as single documents.

4) If you have not saved the original, prototype form letter document (template)
previously, then you should do so now. Having a form letter template could greatly
simplify the creation of other form letters in the future and is highly
recommended.

CHANGING YOUR TOMORROW
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To print mailing labels:
1. Choose File > New > Labels.

2. On the Options tab, ensure that the Synchronize contents checkbox is selected.

3. Onthe Labels tab (Figure 15), select the Database and Table. Select the Brand of
labels to be used. and then select the Tvoe of label.
Labels

Labels Format | Options

Inscription
Label text [] Address Database
~ Points v .
. 0: ' Figure 15: Select Database, Table,
Table
— - label Brand, and label Type.
Database fisld
SExs v
< | >
Format
() Continuous Brand Avery A% w
® sheet Type 38160 Address v
18160 Address: 2.50"x 1.50" (3 x 7)
ot T (s [ — | ——

Nl IMMINNJIIYNNG T WVVILY 1] UIVI\JRROW
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4. Click the dropdown arrow under Database field. Select the first field to be used in
the label (in this example, Title). Click the left arrow button to move this field to
the Label text area, as shown in Figure 16.

- = |

R X |
l__a_bél!'_- Format | Opbons
Inscription
Label text [ address Database
<Points.Sheet1.0.Tite > ~ Ports ~
Table
Sheetl L
Database fiald
v (&) [nee v
£ | i >

Figure 16: Move fields from Database field list to Label text area.

CHANGING YOUR TOMORROW
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5. Continue adding fields and inserting desired punctuation, spaces, and line breaks
until the label is composed. Figure 17 shows the combleted label.

-
Labels
n[ai:elsn Format [ Options _
Inscription
Label text [[] Address Database
<Points.Sheet1.0.Title > <Points.Shet/ s | Poi .
<Points. Shoet1 0 Addems [Points L Figure 17: The completed label.
<Points.Sheet1.0.5tate /County > Table
<Points.Sheet1.0.Post Code >
<Points.Sheet1.0.Country > = Sheetl v
Database field
™ [ 4 ] Country v
< .| >
Format
(O Continuous Brand Avery A4 [ 1
@ Sheet Type 138160 Address )
18160 Address: 2.50" x 1.50" (3x 7)
I Mew Docurnent ] [ Cancel ] [ Help ] [ Reset ]
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Click New Document. You now have a new, single-page document containing a series of frames,

one for each label of the selected type and filled with the data source address fields that you
selected. Quite often some of the fields in your address data source will be unused, leading to
blank lines in your labels. If this is not important, you can skip the next few paragraphs and go
straight to Step 7, otherwise continue as described here.

a)

b)

First ensure that the label frames are showing the field contents (data source headings),
rather than their underlying field names. If this is not the case, then either press Ctrl+F9 or
choose View > Field Names to toggle the view.

Next, ensure that you can see non-printing characters, such as paragraph marks, line breaks
and so on. If these are not already visible, choose View > Nonprinting Characters from the
menu bar, or press Ctrl+F10, or click on the paragraph icon ¥ in the Standard toolbar.

You will now see that address field separation is created by line breaks — , rather than
paragraphs 9. As the suppression of blank address fields depends on hiding paragraphs, not
lines, you need to replace line breaks with paragraphs as follows.

Click in the first label, at the end of the last data source address field in the first line of the
label. Press Delete to remove the new line character and then press Return (or the Enter
key) to insert a paragraph marker. Repeat this action for each line in the address. If the line
spacing in the first label is not satisfactory, you may wish to correct this before proceeding,
by modifying the paragraph style associated with the address. Unless you have changed it,
the address uses the Default style.

CHANGING YOUR TOMORROW
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d) Click again at the end of the first paragraph to be conditionally suppressed and
then choose Insert > Fields > Other. Select the Functions tab and then click on
Hidden Paragraph in the Type column. Now click in the Condition box and enter
the details of the condition that defines a blank address field. It has the general
form of:

I[Database. Table. Database field] where the ‘I’ (NOT) character indicates the
negative case and the square brackets indicate the condition. For example, in our
Points database the condition to test if the Company field is empty would be
I[Points.Sheetl.Company] as illustrated in Figure 12. To test for multiple
conditions, use the operators AND and/or OR between the conditional
statements, for example:

I[Points.Sheet1.Title]AND
I[Points.Sheetl.Last Name]
Click Insert, but do not close the dialog box until all lines have been amended.

e) Repeat for each paragraph to be conditionally suppressed, remembering to
advance the cursor to the end of the line in question before changing the last

element of the condition and Inserting the result.
CHANGING YOUR TOMORROW
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f) Remembermg that we selected Synchronize contents earlier, you should now be able to
see a small window containing a button labelled Synchronize Labels. Click on this
button and the hidden paragraph fields are propagated to all the labels in your
document.

You now have a template suitable for future use with the same data source and type of
label. If you wish to save it, use either File > Templates > Save as, or save it as an Open
Document Text Template (.ott) into the private template directory (folder) that you have
previously defined in

Tools > Options > OpenOffice.org > Paths > Templates.
The labels are now ready to be printed.
1. Choose File > Print. The message shown in Figure 13 appears. Click Yes.

2. In the Mail Merge dialog box (Figure 14), you can choose to print all records or selected
records. To select records to be printed, use Ctrl+click to select individual records. To
select a block of records, select the first record in the block, scroll to the last record in
the block, and Shift+click on the last record.

3. Click OK to send the labels directly to the printer. If you prefer to save the labels to a
file, perhaps to allow some later editing such as changing the typeface or paragraph
format, then you should select File in the output section of the Mail Merge dialog box,
rather than using the default Printer selection. This changes the dialog box to highlight

the Save merged docurEeﬁksrscéllw SrLeJ [:Szagll_%aﬁ%ﬁRe document is preselected.
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In this case, clicking OK brings up the Save as dialog box, where a file name can be
entered for the saved labels. If you did not save the prototype label fields document
(template) in step 6f, then you are prompted to do so now by another Save as dialog
box.

In either case, whether printing or saving to file, despite there apparently being only
one page of labels, the printed or saved output will be expanded to include all of the
selected records from the data source.

CHANGING YOUR TOMORROW
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To edit a saved file of mailing labels, open the saved label file in the normal way. You
will be prompted as to whether you wish to update all links. Choose No for the
following reason: The first label on the page is termed the “Master Label” and all
other labels are linked to it. If you update the links, then all labels will end up
containing the same data, which may not be what you want.

You can edit individual records in the normal way, by highlighting and changing the
font name, for example.

However, you cannot edit all labels globally (for example, to change the font name for
all records) by the technique of selecting the entire document. To achieve this result
you have to edit the paragraph style associated with the label records as follows:

1. Right-click any correctly spelled word in a label record. Select Edit Paragraph Style
from the pop-up menu. (Note: If you click on a misspelled word, a different menu
appears.)

2. Then from the Paragraph Style dialog box, you can make changes to the font
name, the font size, the indents, and other attributes.

CHANGING YOUR TOMORROW
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a form letter

Open a new document with File > New > Text Document and start the Mail Merge
wizard using Tools > Mail Merge Wizard. The wizard opens, as shown in Figure 18.

Mail Merge Wizard ES
Steps Select starting document for the mail merge
1. {Select starting dmment Select the document upon which to base the mail merge document

2, Select document type
(%) Use the current document

Insert address block _
() Create a new document

E

Create salutation

() Start with existing document [ Browse. ., ]

Adjust layout

Edit document () Start from a template | Browse... ]

m

7. Personalise document

8. Sawve, print or send | |

[ Help ] [ Mext == ] [ Cancel ]

Figure 18:Select starting document
CHANGING YOUR TOMORROW
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sucaionaL GO Step 1: Select starting document

The wizard gives various options to select your starting document:
e Use the current document.

* Create a new document.

 Use atemplate.

* Use an existing document.

For the purposes of this description we assume that you opened a new text
document. This will ensure that all the steps in the wizard are fully explored, although
with experience you may find it more practical to use a draft you prepared earlier,
which will allow skipping some steps. Select Use the current document and click Next.

CHANGING YOUR TOMORROW
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fucaonaLcror - Step 2: Select document type
 The wizard can produce letters or, if a Java Mail connection exists, email messages.

You can see these options in Figure 19. In this example, we are producing a letter.
Select Letter and click Next.

- -

Mail Merge Wizard
Steps Select a document type

1. Select starting document What type of document do you want to create?

3. Insert address block ) E-mail messags

4, Create saiutation Letter:

5. Adjust layout Send letters to a group of recpients. The letters can contain an address block and a salutation,

- and can be personalised for each recpent.

6. Edit document

7. Personalise document

8. Save, print or send

[ Heip ] L << Back } [ Next >> J [ Cancel ]

Figure 19: Choose document type
CHANGING YOUR TOMORROW
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This is the most complex step in the wizard. In this step you will do three things:

1. Tell the wizard which data source to use. The data source must be an existing
file; in this example it is the “Points” spreadsheet created earlier.

2. Select the address block to use in the document. This means choosing which

fields appear (for example, whether the country is included) and how they
look.

3. Make sure that the fields all match correctly.

This is very important. For example, the wizard has a field called . If your spreadsheet
has a column called “Surname”, you need to tell the wizard that and “Surname” are
equivalent. This is described in “Matching the fields”

CHANGING YOUR TOMORROW
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’ v ‘gl ¢ = RS 1
Mail Merge Wizard
Steps Insert address block
1. Select startng doocument 1. 1. Select the address kst contaning the address data Select Addr .
you want to use. This data is needed to aeate the [ DifferentAgdreas List.o J
2. Select document type address blodk. Current address list: Points

2. [¥] This document must contain an address block
<., Create salutaton

<Titde> <Forename> < <Title>
S. Adjust layout <Address Line 1> <Forename> <Sumam=s>
<Regon> <Address Line 1>
Edit document <Postcode > <Postcode > <City>
- g wy> <Country > | More... ]

[¥] suppress lines with empty fields

N9

Save, print or send

3. Match the field name used in the mail merge to the column headers in I lliﬁ‘ﬁgﬁ"l I
your data source. -

4. Check that the address data matches,

Mrs. Alce Azure
1, Frst Avenue
Average Tovwn
Ampshire

AAl 1AA

| Document: 1 [« ()
| tielp ] [ <<sack J[  1ext>> | Sesh [ concet |

Figure 20: Insert address block
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1.

If the current address list, |dent|f|ed
beneath the Select Different
Address List button in section 1, is
not the one you wish to use, click
the button to open the Select
Address List dialog box for choosing
a data source.

If you have not already created the
address list, you may click Create to
do so now. This step will allow you
to create a CSV (Comma Separated
Values) file with a new list of
address records. If you already
have an address list, as we have in
the “Points” spreadsheet example,
but which is not the one you wish
to use, click Add and select the file
in which it resides. In each of the
above cases a new data source will
be created and registered.

Website: www.odmegroup.org
Email: info@odmps.org

Selecting the data source (address list)

Select Address List

ﬂ

Select an address list. Click ‘Add..." to select recipients from a different list. If you do not have an
address list you can create one by dicking ‘Create...".

Your redpients are selected from:

Name Table | [ Add... ]
AddressBook
. SRS [ P—— ]
| Eiter... ]
[ OK J [ Cancel l I Help

CHANGING YOUR TOMORROW

Figure 21: Select address list dialog box

3. Select the address list and click OK to
return to step 3 of the wizard. For this
example, the preceding steps are all you
need to do. The wizard can also exclude
certain records; click Filter to choose them.
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1. In step 3 of the wizard (shown in Figure 20), look at section 2. This is where you
select the address block to appear on the letter, and define its appearance and the
fields it contains. The main page gives two examples. If neither of those is exactly
what you want, click More to see more choices, in the Select Address Block dialog
box (shown in Figure 22).

2. The Select Address Block dialog box offers six choices for the format of the address
block (scroll down to see the last two choices). You can also optionally include or
exclude the country (for example, only include the country if it is not England). The
six formats provided are relatively common, but they might not exactly match your
preference. If this is the case, select the address block that is closest to what you
want and click Edit, which opens the New Address Block dialog box.

CHANGING YOUR TOMORROW
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(s T - - ~
Select Address Block E
Select your preferred address block
<Title> <Forename> <Surname> |<Title> -~ ﬁéw:
<AddressLine 1> <Forename > <Surname > >
<Region> <Address Line 1> Edit...
<Postcode > <Postcode > <City> 3
<Country> <Country> = Delete
<Company Name> <Company Name >
<Forename > <Surname > <Forename > <Surname > ——
<Address Line 1> <Address Line 1>
<Postcode> <City> <Postcode > <City>
<Country> X
~
Address block settings

(O Never indude the country/region

(O Always indude the country/region

(&) Only include the country/fregion if it is not:
Endland

Figure 22: Select address block
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3. In the New Address Block dialog box (Figure 23), you can add or delete address
elements using the arrow buttons on the left. To move elements around, use the
arrow buttons on the right. For example, to add an extra space between first and
last names in Figure 6, click and then click the right arrow button.

New Address Block
Address glements 1. Drag address elements here
Title <Title > <Forename> <Surname> E]

Forename <Address Line 1>
sSurname
Company Mame

(=)
Address t:: ; [E

City

F.egion

Postoode Preview
Country
Telephone private Mrs. Ahcg Azure
Telephone business 1, First Avenue
E-mail Address Average Town

zender

Figure 23: New address block

CHANGING YOUR TOMORROW
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Finally, it is time to match the wizard’s fields with the spreadsheet fields, so that items
like and “Surname” match correctly.

1) Look at section 3 of step 3 of the wizard (shown in Figure 20). The box at the
bottom displays one record at a time, using the address block format you selected.
Use the right and left arrow buttons below that address box to step through the
addresses, checking that they display correctly. Do not assume that all the records
display correctly, just because one or two do. Check them all if you can, or at least
a good proportion.

2) If the addresses do not display correctly (and they probably will not right away),
click Match Fields.

CHANGING YOUR TOMORROW
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Match Fields

Assign the fields from your data source to match the address elements.

Address elements Matches to field: Preview |
)
<Title > Title v Mrs,
<Forename > First Name v|  Alice
<Surname > Last Name 1] Azure
Last Name A
<Company Name > Address
_ State/County .
<Address Line 1> Country 1, First Avenue Average ...
_ Post Code ™
<Address Line 2> <Tone > v "
Address block preview
Mrs. Alice Azure
1, First Avenue
Average Town
| oK | [ Cancel l | Help

Figure 24: Match fields dialog box

Website: www.odmegroup.org
Email: info@odmps.org
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Matching the fields

The Match Fields dialog box has three

columns:

+* Address Elements are the terms the wizard
uses for each field, such as <First Name>
and <Last Name>.

*»*» Use the Matches to Field column to select,
for each address element, the field from
your data source that matches it.

** The Preview column shows what will be
shown for this field from the selected
address block, so you can double-check
that the match is correct.

Toll Free: 1800 120 2316
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3. When you have matched all the fields, click OK to return to step 3 of the wizard.
Now, when you use the arrow buttons to look at all the addresses, they should all
look correct. If not, go back and change anything you’re not happy with, before
clicking Next to move to step 4. Note that you will not be able to continue until
you have correctly matched all the fields in your chosen address block. If you see
in a field position it indicates that the field in question is not correctly matched.

4. Notice the option for Suppress lines with empty fields. Using the Wizard, you do
not have to create your own conditional suppression fields.

CHANGING YOUR TOMORROW
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Step 4: Create salutation

The salutation is the initial greeting, for example, Dear Mr Jones. In step 4, select the
salutation that will appear in the letter.

- .\
Mail Merge Wizard
Steps Create a salutation
1. Select starting document This document should contain a salutation
2. Select document type Insert personalised salutation
3. Insert address block Female Dear Mrs, <Surname >, v|‘\
4, Create salutation Male Dear Mr, <Sumame>, v]‘
5. Adjust layout Address list field ndicating a female recipient
6. Edit document Field name Sex v”
7. Personalise document Field value F v/
8. Save, print or send General salutation
To whom it may concem, v/
Preview
Senr e e, ([ aten fiekis... | Figure 25: Create a
S S salutation
Document: 1 @ @
| bep | [ <<Back  J[ dext>> | 5o

Website: www.odmegroup.org
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EDUCATIONAL GROUP Step 4: Create salutation

You can use a different greeting for men and women. To do this, Writer must have
some way of knowing whether a person is male or female. In our spreadsheet we had
a column called Sex. In the section Address list field indicating a female recipient, set
the field name to Sex and the field value to F. The male salutation is then printed for
all men and the female salutation for all women.

Note You do not need to tell 0Oo who is a male, because it assumes that all non-
female records are males.

If you do not select Insert Personalized Salutation, you can use a more general
salutation without referring to the recipient directly, such as “To whom it may
concern”. As in step 3, step 4 of the wizard has a preview pane at the bottom. You
should check more than one record to ensure that other records look the way you
expect.

CHANGING YOUR TOMORROW
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In step 5, you can adjust the position of the address block and salutation on the page.
You can place the address block anywhere on the page. The salutation is always on the
left, but you can move it up and down the page. Use the buttons shown in Figure 9 to
move the elements.

Steps Adjust layout of address block and salutation

1. Select starting document

2. Select document type
3. Insert address block
4, Create salutation

Figure 26: Adjust layout

Zoom Entrepage v

CHANGING YOUR TOMORROW
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In step 6 you have another opportunity to exclude particular recipients from the mail
merge, as shown in Figure 27.

Mail Merge Wizard
Steps Preview and edit the document
1. Select startng document The preview of a merged document is visble now. To see the preview of another document dick
one of the arrows.
2. Select document type
3. Insert address block Recpent 2 | Figure 27: Edit
document
4, Create sautation [ Excude thisr nt
6. Edit document Edit Document

7. Parsonaliee doasesnt \irite or edit your document now if you have not akready done so. The changes wil effect all
8. Save, print or send merged documents.

Clicking ‘Edit Document. ..’ will temporarily reduce the wizard to a small window so you can edit the
mai merge document. After editing the document, retum to the wizard by clicking Return to Mail
Merge Wizard' in the small window.
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You can also edit the body of the document. If you started with a blank document, you can
write the whole letter in this step. Click Edit Document to shrink the wizard to a small
window (Figure 27) so you can easily edit the letter.

Mail Merge Wizard ]
*-JReturn to Mail Merge Wizard

Figure 28: Minimized mail merge wizard

You need to perform another important task in this step. The wizard only inserts
information from the name and address fields, but you may wish to add additional data. In
our example, we want to tell each person how many points they had accumulated during
the year; that information is in the spreadsheet.

To do this:

1) Click Edit Document in step 6 of the wizard.

2) Choose Insert > Fields > Other. The Fields dialog box opens.
3) Click the Database tab.

4) On the left hand side, select Mail merge fields.

5) Under Database selection find your data source (in this example, it is a spreadsheet).
Expand it to see the fields.

6) Click the field you want to insert, then click Insert to insert the field. You can insert any
number of fields any number of times into your mail merge document.

7) Click Close when you are done.

CHANGING YOUR TOMORROW
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Fields X
| Document | References | Functions | Docinformation | Variables _Dlal:ahast _
IType Database selection
Any record B i3 Points -~
Database Mame = [T sheet1 B |
Mail merge fields Tithe
MNext record First Namse
Record number
Last Name
State /County
Cowurviry
Post Code
S —
add database file [ Browse. .. ]
Ll | el
| _insert [ ogose |[ wew |

Figure 29: Insert mail merge fields dialog box

The Database selection lists the data source you selected in

Note

step 3. All the information you need for the letter must be

contained in that data source.
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In step 7, OO0 creates all your letters, one per recipient. Clicking the Edit individual
Document button here is similar to step 6. The difference is that you now edit a long
file containing all of the letters, so you can make changes to a particular letter to one
person. In this step of the Mail Merge wizard (Figure 30), click Find to open a dialog
box that allows searches within the document, perhaps for an individual addressee.

Mail Merge Wizard &
Steps Personalise the mail merge documents .
As with step 6, when
1. Select startng document You can personalise particular documents. Clicking Edit ndividual document...' will temporarily -
reduce the wizard to a small window s0 you can edit your document. After editing the document, editi ng the docume nt,
2. Select document type return to the wizard by dicking 'Retumn to Mal Merge Wizard' in the small window.

the wizard shrinks to a

3. Insert address block

Gl s [ £t ndvidual document... ) small window (Figure
28). Click on this

6. Edit document End window to expand the
. Pe se document Search for: _ 1 i i
7. Personalise document o [ bnd. | wizard to its full size.
8. Save, print or send (] whole words only

[7] Backwards

[ Match case

Figure 30: P lize d t
e S HANGING YOUR TOMORROW
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You have now completed the mail merge process. The last step is to do something
with it. In step 8, you can save the original sample letter, save the merged document,
print the letters right away or, if you created email messages, send them.

You probably want to save the starting (prototype) document and the merged
document. To do this, select Save starting document to reveal the Save starting
document section containing the Save starting document button. This button will be
active only if the document has not already been saved. Clicking on this button brings
up the standard Save as dialog box. Once you have named and saved the document
you return to the Step 8 dialog box as shown in Figure 28.

The merged document can now be saved by selection of Save merged document. This
will reveal the Save merged document settings section, from which you can select to
save either as one large file containing all the individual, generated letters or as a
separate file for each letter. When you have saved the merged document, you can
print the final letters now or later; and you can still manually check and edit the letters
if necessary. If you elect to print at this stage, the dialog box shown in Figure 32
appears; it should be self-explanatory.

CHANGING YOUR TOMORROW
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Mail Merge Wizard w
Steps ~ Save, print or send the document
1. Select starting document Select one of the options below:
2. Select document type (® Save starting document
3. Insert address block O save merged document
_ (O Print merged document
4, Create salutation
() Send merged document as E-Mail
Save starting document
6. Edit document
Save starting document

7. Personalise document

8. iSave, print or send’

Figure 31: Step 8: Save, print or send
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4 ' F— N
Mail Merge Wizard m
Steps Save, print or send the document
1. Select starting document Select one of the options below:
2. Select document type (O save starting document
3. Insert address block (® save merged document
Print
4. Create salutation O Print merged document
(O Send merged document as E-Mail
Save merged document settings
6. Edit document
(®) Save as single document!
7. Personalise documen
- - t (O Save as individual documents
8. Save, print or send e -
[ Save Documents ]

Figure 32: Saving a merged document
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Steps Save, print or send the document
1. Select starting document Select one of the options below:
2. Select document type () save starting document
3. Insert address block © Save __ o e t,
int ocument;
4 ke o (® Print merged document i
() Send merged document as E-Mad
Print settings
6. Edit dooument
Printer Canon MP780 Series Printer v| | Propertes... |
7. Personalise document
. ) , (3) Print 3l documents
8. Save, print or send | :
OFfom |: 30
[ Prnt Documents

Figure 33: Printing the merged document

CHANGING YOUR TOMORROW

Website: www.odmegroup.org Toll Free: 1800 120 2316
Email: info@odmps.org Sishu Vihar, Infocity Road, Patia, Bhubaneswar- 751024



0DM=4» Home Assignment

EDUCATIONAL GROUP
PRACTICAL ACTIVITY
1. Open the Word Processing software and prepare the following labels for
= Schools to invite parents for annual function
= A Tech Magazine who wants to send flyers to its clients

QUESTIONS

1. Explain Mail Merge.
2. What are advantages of Mail Merge?
3. Give examples of databases in which the Data Source can be created.
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Website: www.odmegroup.org Toll Free: 1800 120 2316
Email: info@odmps.org Sishu Vihar, Infocity Road, Patia, Bhubaneswar- 751024



0DM =4

EDUCATIONAL GROUP

THANKING YOU
ODM EDUCATIONAL GROUP

0DM=—4»

EDUCATIONAL GROUP
Changing your Tomarrow M

CHANGING YOUR TOMORROW

Website: www.odmegroup.org Toll Free: 1800 120 2316
Email: info@odmps.org Sishu Vihar, Infocity Road, Patia, Bhubaneswar- 751024



